Get in touch
Back
Downtime

Internet Connection Down

Started 9 Feb at 08:00am CET, resolved 11 Feb at 02:25am CET.

https://www.specialfalgar.se https://www.spesialfelger.no https://www.erikoisvanteet.fi
Resolved

Our internet connection is now restored!

Posted 11 Feb at 02:25am CET.
Updated

The connection issues continues today and our supplier as made a new estimation regarding when this can be resolved.

Right now the estimation is Friday 18.00

Posted 10 Feb at 08:29am CET.
Created

Right now our internet provider are having major issues with our connection.

This disturbance affects or website, webshop and all other webservices.

We haven't received any estimation for when this might be fixed.

Posted 9 Feb at 08:00am CET.